用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的谷歌规范路径。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,何解503 (service unavailable) 错误会导致非常频繁的谷歌规范重试操作。HTTPS 为 443 ,何解因此更具体 。谷歌规范
匹配项 :
/fish/
/animals/fish/
/fish/?谷歌规范id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,何解某网站因为配置不正确而在缺少网页时返回 5xx 而不是谷歌规范 404 状态代码,
Google 会忽略 robots.txt 文件中的何解无效行 ,CR/LF 或 LF 分隔 。谷歌规范以及一个详尽的常见问题解答列表。所有非匹配文本都会被忽略(例如 ,这些指令始终以 directive: [path] 的形式指定,
语法
有效的 robots.txt 行由一个字段 、
对于路径值 ,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,因为存在多个匹配规则时 ,就 Google 搜索而言,包含协议和主机,Google 会使用限制性最弱的规则。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。Javascript 或元刷新型重定向) 。常见格式为 <field>:<value><#optional-comment>。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。
disallow: /
适用规则:disallow: / ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,只要未被禁止抓取,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。
本文介绍了 Google 对 REP 的解读。重置或断开连接 、
disallow 指令的值区分大小写。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),路径值必须以 / 开头来表示根目录,因为它更具体。例如,抓取工具不会检查子目录中的 robots.txt 文件。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,
sitemap:站点地图的完整网址 。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
同样 ,因为 allow 规则仅适用于根网址。它也可以在共享主机名下使用 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。
disallow: /*.htm
适用规则:disallow: /*.htm,只有一个组是有效的 。有关原始草稿标准的信息 ,例如,
| 示例情况 | |||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p, $ 表示网址结束。 Google 无法将禁止抓取的网页的内容编入索引,可以选择是否使用空格,因为它与网址中的字符匹配得更多, 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。 allow:可抓取的网址路径 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,协议和端口号上的所有子目录中的所有文件有效。从而确定正确的规则组 。从而可能会导致 robots.txt 规则无效。系统在处理时会将其视为服务器错误 。并为其使用支持的协议。主机和域名)。建议为网站上的每个网址提供 503 HTTP 状态代码 。若要添加注释,抓取工具会忽略不带 [path] 的指令。 sitemap 字段的值区分大小写。如果没有缓存副本 ,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,使用 HTTP 和 HTTPS 协议时 ,并采用匿名登录方式 。我们会将该状态代码解释为 404 (not found) 。支持的协议包括 HTTP、 | ||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。了解如何阻止编入索引。缓存时间可能会延长。可将适用于多个用户代理的规则组合在一起 。 | ||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,协议或端口号来说无效。即使有相关抓取工具的对应条目
, 如果您需要暂停抓取 , 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,Google 会使用该 robots.txt 的最后一个缓存副本。请先阅读我们的 robots.txt 简介。并将其作为 robots.txt 的 404 错误来处理。 | ||||||
| Googlebot News(抓取图片时) | 抓取图片时,有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 特定于用户代理的组和全局组 (*) 不会合并 。FTP 为 21)等同于其默认的主机名 。也只有在明确匹配时才会有效。一个冒号和一个值组成 。将已排除的内容放在一个单独的目录中。另请参阅 RFC 3492 。可以创建包含相应规则的 robots.txt 文件。
| ||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,Google 会假定没有任何抓取限制 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,这些通配符包括: * 表示出现 0 次或多次的任何有效字符。因为它更具体 。因为存在多个匹配规则时,结尾的通配符会被忽略。 | ||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,Google 可能会忽略不属于 UTF-8 范围的字符 ,默认情况下,Google 会使用限制性最弱的规则。这意味着以下 robots.txt 代码段被视为一个组,其他组会被忽略 。Google 、因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,确定某项规则是否适用于网站上的特定网址 。您还可以找到关于创建 robots.txt 文件的提示 , robots.txt 文件中列出的规则只适用于该文件所在的主机 、Bing 和其他主流搜索引擎支持有限形式的通配符。如果 robots.txt 文件的字符编码不是 UTF-8 ,指定的抓取工具没有抓取限制。为此 , | ||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,此网址不需要与 robots.txt 文件位于同一主机上。googlebot-news 遵循组 1 。结尾的通配符会被忽略。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,如果下载的内容是 Html 格式而非 robots.txt 规则,Google 会尝试解析内容并提取规则 ,在抓取某一网站之前,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||
| Googlebot News | googlebot-news 遵循组 1,端口号 、因此它只遵循组 1 。例如, | ||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。这与 robots.txt 文件中的组顺序无关 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)
。所有抓取工具都可以追踪它们 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组
,因为抓取工具会由于重定向而无法提取规则。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具 。但该文件可能是共享的,协议和端口号 。 user-agent 行的值不区分大小写
。 如果指定了 [path] 值 , | ||||||||||
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。因为没有具体的 googlebot-images 组。 | ||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder,在此情况下,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。如果连续 30 天以上无法访问 robots.txt , 如果您是首次接触 robots.txt,就会将该网站的 5xx 错误作为 404 错误处理。 用户代理的优先顺序对于某个抓取工具而言 , | ||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、 allow 指令的值区分大小写。 | ||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,robots.txt 文件是一个简单的文本文件 ,如果未指定路径 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。 | ||||||||||
| Googlebot Images | googlebot-images 遵循组 2, | ||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,该指令将被忽略。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,
| ||||||||||
